PEAR::HTML_QuickForm の インストール

【この記事の所要時間 : 約 3 分

「PEAR::HTML_QuickForm」をインストールしようと思って以下のコマンドを打つ。
# pear install HTML_QuickForm
すると、以下のようなエラーメッセージが出てインストールに失敗した。
Did not download dependencies: pear/HTML_Common, use –alldeps or –onlyreqdeps to download automatically
pear/HTML_QuickForm requires package “pear/HTML_Common” (version >= 1.2.1)
No valid packages found
install failed

なるほど。
PEAR::HTML_QuickFormをインストールする前に、
PEAR::HTML_Commonをインストールしておく必要があるみたい。
よってPEAR::HTML_Commonをインストールする。
# pear install HTML_Common
以下のように出たので、うまくインストールされたみたい。
downloading HTML_Common-1.2.2.tar …
Starting to download HTML_Common-1.2.2.tar (-1 bytes)
……..done: 20,992 bytes
install ok: channel://pear.php.net/HTML_Common-1.2.2

次に、PEAR::HTML_QuickFormのインストールに再チャレンジ。
# pear install HTML_QuickForm
以下のようなメッセージが表示されたのでうまくいったようだ。
downloading HTML_QuickForm-3.2.5.tar …
Starting to download HTML_QuickForm-3.2.5.tar (-1 bytes)
………………………………………………………………………………………………………….done: 607,744 bytes
install ok: channel://pear.php.net/HTML_QuickForm-3.2.5

一応、念のためインストールされているかコマンドで確認する。
# pear list
インストール済みパッケージとしてPEAR::HTML_QuickFormが表示されていたのでOK。
これでPEAR::HTML_QuickFormが使えるようになる!わーい。

PEAR入門 PHP標準ライブラリを極める!
山田 祥寛
翔泳社
売り上げランキング: 312,487
スポンサーリンク
レクタングル(大)広告
  • このエントリーをはてなブックマークに追加
スポンサーリンク
レクタングル(大)広告

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です