phpMyAdminの管理画面にて「扱えない拡張子のファイルです」というエラーが発生!

【この記事の所要時間 : 約 3 分

久しぶりに、自宅サーバのphpMyAdminを使おうと思って管理画面を見ると・・・
「扱えない拡張子のファイルです,PHP の設定をチェックしてください」
というエラー画面が表示された。
あれ?ということでgoogle先生に聞くと・・・・
ちなみに自宅サーバの環境は、以下の通り。
 ・OS : Vine Linux 3.2
 ・Webサーバ : apache 1.3.34
 ・PHP : 5.1.2
 ・MySQL : 5.0.18
で、phpMyAdminのエラー問題だが、
原因:
php5以降は、mysql/mysqliエクステンションはデフォルトでは組み込まれないため、phpにmysql(i)エクステンションが組み込まれていなかったから。
2006/02/20にPHP 4.4.2 から PHP 5.1.2 にバージョンアップをしたのが原因っぽい。たしかに2006/02/20以降、はじめてphpMyAdminの管理画面を見たような気がする。
参考ページ
対策:
PHPにmysqliエクステンションを入れる!
参考ページ
自宅サーバにおける「mysql_config プログラムが存在するパス」を調べると、「/usr/local/bin」だったので、configureに以下のように付け加える。
コンパイル、インストールコマンドは以下。(もちろんソースからインストール)

# ./configure –with-mysqli=/usr/local/bin/mysql_config –with-apxs=/usr/local/apache/bin/apxs –enable-mbstring –enable-mbregex

# make

# make install

そして、apacheを再起動すると、phpMyAdminが使えるようになった!
ということで無事問題解決!
P.S. ちなみに「扱えない拡張子のファイルです,PHP の設定をチェックしてください」というエラーメッセージは誤訳ですので、気をつけてくださいね。

いきなりはじめるPHP~ワクワク・ドキドキの入門教室~
谷藤賢一
リックテレコム
売り上げランキング: 5,502
スポンサーリンク
レクタングル(大)広告
  • このエントリーをはてなブックマークに追加
スポンサーリンク
レクタングル(大)広告

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です