phpMyAdmin インストール

【この記事の所要時間 : 約 2 分

エラー発生
インストールした後、ブラウザにてアクセスすると
「”#1251 – Client does not support authentication protocol requested by server;consider upgrading MySQL client” 」というエラーが発生した。
原因
phpMyAdminがMySQL 4.1.* 以降のパスワードハッシュに対応していないため。16ビット時代に使われていた暗号化されていないパスワードを使うようにしてやらないといけない。MySQLのパスワードを旧パスワード形式にて再作成する必要がある。
参考サイトはこちら
対策
mysql> SET PASSWORD FOR root@localhost =OLD_PASSWORD(‘******************’);
結果
アクセスできるようになった!
phpMyAdminがうまくインストールできたが、このままだと、誰でもこのデータベースにアクセスできてしまうので、ベーシック認証をかけてアクセス制限をする。
ユーザー認証によるアクセス制限(ベーシック認証編)

いきなりはじめるPHP~ワクワク・ドキドキの入門教室~
谷藤賢一
リックテレコム
売り上げランキング: 5,502
スポンサーリンク
レクタングル(大)広告
  • このエントリーをはてなブックマークに追加
スポンサーリンク
レクタングル(大)広告

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です